Support Article
Getting ConnectionPoolTimeoutException from logs
SA-25825
Summary
When attempting to load test while invoking SOAP web services, repeated ConnectionPoolTimeoutExceptions are thrown in logs.
Error Messages
Exception
com.pega.pegarules.pub.services.ResourceUnavailableException: SOAP service failed
Caused by: com.pega.apache.commons.httpclient.ConnectionPoolTimeoutException: Timeout waiting for connection
Steps to Reproduce
Invoke web service during performance tests.
Root Cause
Due to load test the pool was being exhausted during the runs.
Resolution
Axis2 defaults MaxTotalConnections and MaxHostConnections to 20 and 2 respectively. PRPC defaults them to 1000 and 100 respectively. Given that the timeout is happening while acquiring a connection, user must increase the number of connection and max host connections:
This can be done through the DSS settings below:
a) Purpose : Axis2_Max_Connections
Ruleset : Pega-IntegrationEngine
Value : 1000
b) Purpose : Axis2_Max_HostConnections
Ruleset : Pega-IntegrationEngine
Value : 100
Published July 27, 2016 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.