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Support Article

Unable to edit delegated rules

SA-33212

Summary



When application is on Pega 7.1.8 user had delegated a few decision tables to a particular access group.

Now their application has been upgraded to Pega 7.2.1 and they have included Pega Client LifeCycle Management (CLM) as well.

After the upgrade they are unable to edit the delegated rules as one of the when condition is returning false in one dev environment.


Error Messages



This item has limited configuration access.
Switch to Case Manager portal to configure this delegated item.


Steps to Reproduce

  1. Delegate a decision table in Pega 7.1.8 application.
  2. Upgrade application to Pega 7.2.1.
  3. Try to edit the delegated decision table.


Root Cause



When the dynamic container with single document mode is used "pxIsPortalSingleDocument" when condition becomes True and in appropriate edit buttons become visible.

Resolution



Change the dynamic container from single document mode to multi document mode.

When changed this, user had another issue where the header layout was missing.

This is because on the header icons, user configured "Replace Current Harness" action.

Modify this action to launch harness in "New Document".


Published February 13, 2017 - Updated October 8, 2020

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