Support Article
Cover count open -1 error while withdrawing cases
KCP-356
Summary
A Cover Open Count error occurs when withdrawing a case.
Error Messages
The Cover Open count is incorrect; it is -1
Steps to Reproduce
- Open the parent case.
- Select the Withdraw Work option from the Action menu.
Root Cause
An issue in the client application code or rules.
The standard ticket Status-Resolved was leveraged within a custom flow before a call to functionality to change to a Resolution stage. Since the Status-Resolved ticket is invoked during resolution of a work object, a loop scenario occurs where the Cover Count is decreased multiple times, ultimately beyond 0, causing the process to fail.
Resolution
Perform the following local-change:
Modify the custom flow to avoid re-entering resolution processing after the Status-Resolved ticket is raised.
Published December 2, 2021
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