Support Article
Intermittent LockGoneException in the log file
SA-38745
Summary
User is using PRPC 6.3 SP1 with Pega CS for Financial Services 6.3.1.
User reports intermittently that the assignment is processing error while working on the case. When they analyzed the log they found out that there are lot of "LockGoneException" error message in the log frequently.
Error Messages
Error message in the Pega log file.
obj-save failed.
com.pega.pegarules.pub.database.LockGoneException: Save, Delete or Commit has failed because lock "XXXXXXX" is not held
Steps to Reproduce
There is no specific reproducible scenario.
Root Cause
This was determined to be a environment issue, since the Weblogic connection pool settings seems to be too low.
Resolution
User is suggested to fine tune the JDBC Connection pool settings.
Published July 10, 2017 - Updated October 8, 2020
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