Support Article
Multiple TERMINATED application requestors in pr_perf_stats
SA-53294
Summary
User is using Pega 7.2.2 and have an application makes extensive use of headless processing via below Pega API calls:
POST - /cases
GET - /cases/{ID}
PUT - /cases/{ID}
If the authentication is enabled for the Pega API calls in the Service package then for each Pega API call, system is writing a record to pr_perf_stats table.
This doesn't happen when authentication is disabled. The requestor types are terminated. Around 275,000 daily rows are added to pr_perf_stats where the row is for a terminated application requestor with pxProcLabel ServicePAL.Rest.api.v1.cases. It appears that every call to the Pega API generates a row in pr_perf_stats. Due to heavy usage of authenticated Pega API calls, there is frequent database activity on this table which is a concern.
Error Messages
Not Applicable
Steps to Reproduce
- Open the Pega instance.
- Make a Pega API call for an authenticated requestor (for example: GET /cases/{ID} and pzInsKey of the case as ID for this case as parameter).
- Verify the PR_PERF_STATS table. A record would have been written to this table for terminated application requestor type.
Root Cause
The issue was determined to be a product enhancement request.
Resolution
An enhancement request, FDBK-25244, has been created for consideration by Pega Product Management.
Published July 23, 2018 - Updated October 8, 2020
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