Support Article
Email listener failing continuously with FolderClosedException
SA-59572
Summary
FolderClosedException generated in the log files multiple times.
Error Messages
caught javax.mail.FolderClosedException when processing message number 9
javax.mail.FolderClosedException
at com.sun.mail.imap.IMAPMessage.getProtocol(IMAPMessage.java:169)
at com.sun.mail.imap.IMAPMessage.loadFlags(IMAPMessage.java:1546)
at com.sun.mail.imap.IMAPMessage.isSet(IMAPMessage.java:1021)
at com.pega.pegarules.integration.engine.internal.services.email.EmailListener.emailProcess(EmailListener.java:3718)
at com.pega.pegarules.integration.engine.internal.services.email.EmailListener.oneIteration(EmailListener.java:2883)
at com.pega.pegarules.integration.engine.internal.services.email.EmailListener.run_(EmailListener.java:2749)
Steps to Reproduce
Run the email listener.
Root Cause
A defect or configuration issue in the operating environment.
Resolution
The folder on the email server is closed when it has an issue. The email listener does not expect the folder to be closed and continues processing the email. Despite the occurrence of FolderClosedException, the email listener tries to process the email. Exceptions are logged and the emails are not read until the folder is reopened. On the next run, the folder is reopened and the email is processed.
An enhancement request, FDBK-26911, is created for consideration by Pega Product Management to improve the email listener's behavior in terms of folder management.
Published July 23, 2018 - Updated October 8, 2020
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