Support Article
Oauth2 Refresh token is not available
SA-71187
Summary
OAuth 2.0 provider supplies the Refresh Token only once in the first time response of the token endpoint. When the token expires the first time, a new Access Token is obtained using the refresh token. When the Access Token expires the second time, the new Access Token is not generated automatically.
Refresh Token does not persist in the Data-Admin-Security-OAuth2-AccessToken instance.
Error Messages
Not Applicable
Steps to Reproduce
Enable the Use Refresh Token checkbox.
Root Cause
A defect in Pegasystems’ code or rules.
When the Access Token expired, Pega internally manages obtaining a new Access Token using the Refresh token. However, when the new token (which is retrieved using the Refresh Token) expires, Pega table does not have the Refresh Token.
Resolution
An enhancement request, FDBK-29667, is created for consideration by Pega Product Management.
Published March 12, 2019 - Updated October 8, 2020
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