Support Article
Segment does not populate results
SA-72957
Summary
Post Pega Marketing (PM) 7.2.2 upgrade to PM 8.1, the segments do not complete when run. The status displays 'Currently running' despite the segment never completing and populating results.

Error Messages
Not Applicable
Steps to Reproduce
- Create a segment in the Pega Marketing portal.
- Run the segment.
Root Cause
A defect or configuration issue in the operating environment.
The Pega Marketing agent for ruleset PegaMKT-Engine was not running.
Resolution
Perform the following local-change:
- Ensure that the PegaMKT-Engine agent schedule is enabled (according to the Installation guide).
- Ensure the agent is running.

Tags:
Published March 20, 2019 - Updated December 2, 2021
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.