Support Article
pxChildWaitElapsed showing huge values
SA-65473
Summary
Performance degrades for Service Soap Requests' response. Majority of the time used is for pxChildWaitElapsed.
Error Messages
PEGA0011
Steps to Reproduce
Run through the application.
Root Cause
The issue occurred due to the following,
- The batch thread pool is exhausted. Hence, the batch task waited in the queue until one of the threads was free to pick up work.
- The batch task itself took that amount of time.
Resolution
Perform the following local-change:
Increase the thread pool size when the batch thread pool is exhausted.
- prpc_j2ee14_jboss6*\META-INF\jboss\jboss-pradapter-ds.xml - Search for the max-pool-size and change to 100.
- prpc_j2ee14_jboss6*\pradapter\META-INF\ironjacamar.xml - Search for max-pool-size and change to 100
Additionally, in the stand-alone-full.xml, change the max-pool-size to 100 as below,
- <strict-max-pool name="mdb-strict-max-pool" max-pool-size="100" instance-acquisition-timeout="5" instance-acquisition-timeout-unit="MINUTES"/>
- <strict-max-pool name="slsb-strict-max-pool" max-pool-size="100" instance-acquisition-timeout="5" instance-acquisition-timeout-unit="MINUTES"/>
Make the changes, repackage the EAR file, deploy, restart the server, and verify for PEGA0011 alerts.
When the batch itself takes a long time, it is recommended to fine tune the service for faster response.
Published March 24, 2019 - Updated October 8, 2020
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