Support Article
Lock is not held on Child case when opened directly using search
SA-5447
Summary
From the user's perspective, it was observed that work objects, when opened directly using search by one user, could be opened from a different session as well. The same work object could be opened simultaneously from 2 sessions. Subsequent behavior indicates the lock is held. The user that has opened the assignment first can submit the work object, the second user receives a message “You have lost the ability to make changes…” which indicates they do not have the lock.
Error Messages
“You have lost the ability to make changes…” after the work object is opened and submitted by the second user.
Steps to Reproduce
- Seach for any work object
- Open the assignment
- Open another session and log in as a different user
- Search for the same work object
- Click on the assignment
Root Cause
The root cause of this problem is a defect in Pegasystems’ code/rules. In this case the work object class had an Access Deny rule, execution of which will reset step status "fail" set by Lock Manager
If an Access When rule executes as part of evaluating whether current thread authorization has access to work class it can reset the ProcessingStatus on current PRStackFrame. Pass an additional boolean to capture status of Access When execution on a new ProcessingStatus on stack. In this case it was resetting Fail processing status set by Lock Manager,
Resolution
This issue is resolved by hotfix item HFix-20590.
Published January 31, 2016 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.