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Support Article

Action set does not execute in order for Navigation rule

SA-49813

Summary



User has configured the following 3 actions in the action set:
  1. Run Activity
  2. Refresh Harness
  3. Open Assignment

The configuration does not execute in order on clicking the the Menu item. The 'Open Assignment' step executes first, resulting in an error.


Error Messages



Empty assignment key alert in UI.


Steps to Reproduce

  1. Create a navigation rule with 3 actions in the action set
  2. In the Run activity, set the assignment key which should be opened in the Open Assignment step


Root Cause



This issue was determined to be a product enhancement request as the change tracker was not implemented for the menu.


Resolution

Perform the following local-change:
  1. Create a TestProperty property in the section with the menu
  2. In the menu, use a section refresh as shown below and then write the code for opening the assignment in the UserWorkForm as below:

function TestFunction(TestProp){
setTimeout(function(){
var x = pega.u.property.toHandle(TestProp);
debugger;
var selector = "[name='"+x+"']";
var name= document.querySelector(selector); var y= name.value;
console.log(y);
openAssignment(name.value); }, 1000);
}






Published February 13, 2018 - Updated October 8, 2020

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