Support Article
Add task overlay does not render after deleting task
SA-30760
Summary
When removing a task from the Customer Service (CS) Interaction Task sidebar, then immediately clicking on the Add task button, the Add Task overlay is not displayed.
This is most noticeable in Internet Explorer, though is possible to reproduce in FireFox and Chrome browsers.
Error Messages
Not applicable
Steps to Reproduce
1) Launch a demo pop case and add several tasks to the interaction.
2) Navigate to a task to start it (example: Address Change).
3) Navigate to a different task.
4) Delete the task in step 2 (Address Change) by clicking the 'X' icon, the quickly click the "Add Task" button.
Root Cause
The design of the CS Interaction driver sections, refreshes, and control actions can cause an invalid DOM to be the target of the "Add Task" overlay when the user interactions are timed too closely together.
Resolution
The "Add Task" overlay will correctly launch if the button is clicked again, or if the user waits a small amount of time between closing the task and clicking the button.
Additionally, the behavior of the Interaction Task sidebar has been logged as a feature enhancement request with the CS Framework Product team so that it may be evaluated for changes and enhancement in a future version of the CS Framework.
Published January 12, 2017 - Updated December 2, 2021
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