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Support Article

After installing CPMHC 7.13 DesignerStudio menu not found

SA-14617

Summary



After installing Customer Service Health Care (Formerly CPMHC) 7.13, when logging in with the OperatorID CPMHCSysAdmin, the Developer Portal opens, but it does not have the DesignerStudio menu. An error is captured in the log file when this occurs.


Error Messages



Caused by:
 com.pega.pegarules.pub.generator.RuleNotFoundException: Failed to find a 'RULE-NAVIGATION' with the name 'HCSAMPLEPROCESSES' that applies to 'Pega-Landing'. There were 2 rules with this name in the rulebase, but none matched this request. The 2 rules named 'HCSAMPLEPROCESSES' defined in the rulebase are:
 1 related to applies-to class 'Pega-Landing', but were defined in rulesets which are not in your rulesetlist: 'PegaHealthCodes:07-13-01'.
 1 inaccessible because their availability was 'Withdrawn'.


Steps to Reproduce



User followed the installation instructions from the document and then log into application as CPMHCSysAdmin.


Root Cause



This issue is due to trying to use CSHC version 7.13 with HCIF 7.13. CSHC version 7.13 actually requires HCIF 7.12.

Resolution



Here’s the explanation for the reported behavior: This issue is resolved by installing HCIF 7.12 into the environment.  

 

Published October 6, 2015 - Updated December 2, 2021

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