Support Article
BIX Extract does not extract all records
SA-100220
Summary
The Business Intelligence Exchange (BIX) based on the 'Last Updated Time as Start' filter fails when executed using the Job Scheduler.
Error Messages
Not Applicable
Steps to Reproduce
- Create a BIX Extract rule.
- Execute the rule using the 'Last Updated Time as Start' filter.
Root Cause
This behavior is as per Pega product design.
Resolution
BIX extracts records using the 'Last Updated Time as Start' by comparing the pylastupdatedate in the pr_extract_time table and the pxcommitdatetime column in the relevant work table. Hence, among the records which are not transferred during the time when the extract is not processed completely, the work objects which are updated later to that date are already transferred to the target database.
For the rest of the records, perform the below steps:
- Create a copy of the BIX extract.
- Disable the 'Last Updated Time as Start' filter.
- Apply manual filters to specify the pxcommitdatetime > the DateTime of the last successful execution before extraction failure and pxcommitdatetime < the DateTime when the extract is processed 100% successfully.
- Manually run the extract.
This transfers any lingering work object records that were not transferred during that timeframe and which were not updated since.
Published February 10, 2020 - Updated December 2, 2021
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.