Support Article
Bulk Processing Reassign to user functionality is not working
SA-19592
Summary
When bulk processing in IE11, clicking away from the tab where the worklist appears and clicking back to it causes the tab's contents disappear.
Error Messages
Not Applicable
Steps to Reproduce
- Initiate bulk processing in IE11.
- Select a user's worklist (opens in a new tab).
- Click back to the Bulk Processing tab.
- Click back to the worklist tab.
Root Cause
An issue in the custom application code or rules where older, 6.x style bulk processing rules were being used. The older 6.x style of bulk processing, pyMyProcessActions, was not designed or intended to work with IE11 in standards mode.
Resolution
Perform one of the following local-change options:
- Use the out of the box (OOTB) Pega 7.1 Bulk Processing functionality, pyBulkProcessActions, which was designed to avoid issues of this nature.
- Run in IE’s compatibility mode. Please note that running in compatibility mode could potentially cause problems when using Pega 7.1 functionality, as the Pega 7.1 functionality was developed to work on standards mode and has not been tested in compatibility mode.
For more information regarding IE11 support, and the use of older functionality after upgrading to Pega 7, the following PDN articles can be referenced:
https://pdn.pega.com/documents/support-internet-explorer-11
https://pdn.pega.com/documents/pega-7-platform-ui-element-upgrade-guide
Published February 13, 2016 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.