Skip to main content

Support Article

Cannot connect to JFrog Artifactory

SA-98716

Summary



Post upgrading Pega Platform 7 to Pega Platform 8.2.4, the Repository rule for the JFrog Artifactory does not work correctly.  This occurs when saving the rule and when connecting with an external repository.

Connect REST configuration for the Resource path is set to {hostName}/artifactory/api/system/ping





Error Messages



Error from Tracer file: (Data-Repository)Could not connect to repository




Steps to Reproduce

  1. Log in to Pega Platform 8.2.4.
  2. Use the HTTPS protocol to create the given JFrog Artifactory where authentication is mandatory.

 

Root Cause


The Host ID in the Repository configuration was set without the 'repository' word.
The Pega application cannot connect to the repository using the incorrect path.


Resolution



Perform the following local-change:
  1. Copy the Endpoint URL from Jfrog.

     
     
  2. Use the copied path in the Pega Configuration details of the Repository:

    HOST ID: First part of copied path (till the word 'repository')
    Repository key: The rest of Repository path from the URL



     
  3. Perform the Test connectivity.
Suggest Edit

Published August 7, 2020 - Updated December 2, 2021

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Ready to crush complexity?

Experience the benefits of Pega Community when you log in.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us