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Support Article

Cannot see drop down options on the top of search results

SA-19020

Summary



User do not see drop down options on the top of search results in Designer Studio, to filter or increase the scope of the search.
Rules and Data dropdown, Name drop down, Contains drop down, Scope dropdown, are not displayed when searching for a keyword.


Error Messages



No error messages but cannot see the drop down that filters on the search result ;
 




Steps to Reproduce



Search for a keyword, for example Addwork, in the search text box in Designer Studio and user is unable to see the drop down that filters on the search result.
 


Root Cause



A defect or configuration issue in the operating environment:
The Dynamic System Settings (DSS) for Index configuration were wrongly set. Hence Indexing wasn't working correctly and Searc was not using indexes.


Resolution



Perform the following local-change:
 
1.       Make sure that all the nodes are configured with correct and full directory path for indexing location.
2.       Search for the Dynamic System Settings - DSS ‘indexing/distribution/search_enabled’ and set it to true for all nodes.
3.       Search for the Dynamic System Settings - DSS ‘indexing/distribution/index_enabled’ and set it to 'true' only for primary or indexed node and for rest of the nodes set it to 'false'.
 
Important:
DSS once set on a node is applied for all the nodes, the last step is to make sure that there is one node specific as our primary node. 
Once index_enabled is enabled on primary node, add it on search setting landing page, perform re-indexing for the primary node. 
Add the remaining nodes, it replicates the DSS and indexing files from the primary node.
As index_enabled DSS is set to true for rest of the nodes once user has included them after adding primary node.
 
Result : Drop down options appeared in search results.

Published January 26, 2016 - Updated October 8, 2020

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