Support Article
Case manager worklist not refreshed
SA-7102
Summary
When ever end user is working on the case user portal, if he select a particular WO from the WB ,it is getting opened in the same tab and he can work on it. But after closing it, the screen(generally the WorkBasket is not updating) is not refreshing, so when the end user again tries to open the Workobject from same WB since the WO moved to next assignment an error is thrown.
Error Messages
Unable to open instance using given inputs.
Steps to Reproduce
Open a case from worklist and move the case forward.
Close the work item and go to worklist and open the case again
Root Cause
This is expected PRPC behaviour and not a BUG.
Resolution
This issue is resolved through the following local change:
The worklist is getting refreshed after applying the refresh when condition “Declare_pzRecentsCache.pxUpdateDateTime Changes” for the refresh scenario in the embedded section of the dynamic layout.
Changes in worklist rule :-
Data-Portal.pyCMMyWorklist
Changes in workbasket rule :-
Data-Portal.CTMWorkBasketsView
Published January 31, 2016 - Updated October 8, 2020
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