Support Article
Cases not resolved after calling update case activity
SA-69057
Summary
User has a process that sets a ResetPayoff ticket when resolving a case. Post update to Pega 7.3.1, the case does not resolve correctly and is instead routed to PayoffMainFlow.
Error Messages
Not Applicable
Steps to Reproduce
- Update Pega 7.1.8 to Pega 7.3.1
- Resolve a case using the Update Case activity passing a Resolved status.
Root Cause
The issue occurs when PayoffMainFlow and RouteAndProcessException flows are present on the work object. The ResetPayoff ticket is present in both flows. In the PayoffMainFlow flow, the ticket is on the Assignment shape. While, in the RouteAndProcessException flow, the ticket is on the End shape. The SetTicket code iterates through the pxFlow pages. If a ticket is present on the flow, then it starts the flow from that point.
In the Pega 7.1.8, the iteration processes the RouteAndProcessException flow first. Hence, this is working correctly. In Pega 7.3.1, the iteration goes through the PayoffMainFlow first.
Resolution
Perform the following local-change:
Use a different ticket name in the flow such that the same ticket is not present in both the flows.
Published December 12, 2018 - Updated October 8, 2020
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