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Support Article

Chats not transferred to users in a queue correctly

SA-90488

Summary



When multiple users are logged in and are available, the incoming chats are transferred to the agent that logged in first instead of the agent who is for the longest time.


Error Messages



Not Applicable


Steps to Reproduce



Consider two Agents, A and B.
  1. Agent A logs in to the Pega Chat server.
  2. Agent B logs in to the Pega Chat server.
  3. Submit a Chat request. Agent A receives the request.
  4. Submit another chat request. Agent B receives the request.
  5. Agent B wraps up the chat request.
  6. Wait for five seconds or longer.
  7. Wrap the chat request of Agent A.
  8. Submit a chat request. Agent A receives this Chat request instead of agent B.


Root Cause



This  behavior is as per Pega product design.


Resolution



Here’s the explanation for the reported behavior:

This tie-breaking behavior is as per design. In a higher volume environment, the behavior smoothes out and becomes inconsequential.

Pega Chat 8.3 includes the ability to optionally include CSR Skill and Skill Level in the Assignment algorithm.

In case of a tie, the algorithm falls back to the original 'last accepted chat' (described above).

Published March 28, 2020 - Updated December 2, 2021

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