Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

on click of Save button work object is still in the same state

SA-19880

Summary



Click on 'Save' option in other actions of a phone call is not working.


Error Messages



No Error Messages


Steps to Reproduce



1. Create new Phone call.
2. Fill the desired fields and navigate to Member 360.
3. Configure 'Save' menu item with the action 'Save' but still no action is performed on the screen.
4. And developer wants to close the work object on click of Save.


Root Cause



We could see from the UI inspector, there are no actions configured on click of the 'Save' item which has been configured as menu item.

For menu items, the changes to be picked, there is a flag 'pyMenuFlag' to be set to true. At developer end the flag was set to false. So the configurations were not picking up.

Resolution



Perform the following local-change:

1. Go to Designer Studio -> User Interface -> HTML5 Application Readiness and click on ‘Upgrade Show Menu’ option to pick the menu item action configurations.
2. Now go to the menu option and on click of the menu item  configure Save and Cancel actions.

 

Published February 18, 2016 - Updated December 2, 2021

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us