Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Clipboard page vanishing after upgrade from 7.1.7 to 7.1.8

SA-22299

Summary



A custom harness is used for search functionality. Once data is entered into the harness and a search performed, it is expected that the user can return to the harness and modify the search criteria before searching again.  

The search fires a pre-activity which is of the class of the search harness.  On subsequent searches, the system fails to find the pre-activity because it does not know the class of the activity.


Error Messages



'Error message Failed to find instance @baseclass.CaseSearch of type Rule-HTML-Harness.'
 

Steps to Reproduce

  1. Create link in the header of Case worker portal.
  2. Link a harness with section with user interface (UI) control and search results. 
  3. Configure a activity that calls report definition with input parameter from the screen.
  4. Click Search button.


Root Cause



An issue in the custom application code or rules.  

The search harness has a UI action set associated with it.  One of the actions is "Harness" which effects a refresh of the harness.  There is an option on this action set to reuse the existing page or to replace the existing page.  It was set to "
ReplaceCurrent", which blows away the clipboard page on which the harness is based:


The interesting fact is that the clearing of the existing clipboard page is NOT shown in the Tracer.

From one activity step to the next, the page is wiped clean.

Resolution



Perform the following local-change:

Change the Target option from "ReplaceCurrent" to "New Document".

 

Published April 29, 2016 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us