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Support Article

Code-.SystemPulse DSRA9110E: Connection is closed

SA-20175

Summary



The system pulse agent fails with an error.

Error Messages



Caused by:
com.ibm.websphere.ce.cm.ObjectClosedException: DSRA9110E: Connection is closed.
at com.ibm.ws.rsadapter.jdbc.WSJdbcWrapper.createClosedException(WSJdbcWrapper.java:110)
at com.ibm.ws.rsadapter.jdbc.WSJdbcConnection.activate(WSJdbcConnection.java:2848)
at com.ibm.ws.rsadapter.jdbc.WSJdbcConnection.getAutoCommit(WSJdbcConnection.java:1968)


Steps to Reproduce



Unknown

Root Cause



A third-party product issue:
The connection from Websphere is closed.


Resolution



Make the following change to the operating environment:

Make the following changes in the Websphere Admin Console:
  1. Navigate to Data sources > PegaRULES > WebSphere Application Server data source properties.
  2. Select the following under Connection Validation Properties and save the changes:
    • Validate new connection
    • Validate existing pooled connections
  3. Navigate to Data sources > PegaRULES > Connection pools.
  4. Set the maximum number of connections to 100.

Published November 3, 2016 - Updated October 8, 2020

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