Support Article
Complex question fails to save when switched to rich text
SA-32337
Summary
When developer edits a complex question from Pega Survey in Survey management, the complex question cannot be saved if the question is changed from plain text to rich text.
Error Messages
Not Applicable
Steps to Reproduce
1. Select Survey Management.
2. Create a question page from Survey Management.
3. Create a complex question from Survey Management using plain text and save the question.
4. Find the question from Survey Management, and edit it.
5. Flip the format of the question to Rich Text format.
6. Select Save.
Root Cause
A defect in Pegasystems’ code or rules the validation error is not cleared.
Resolution
Apply HFix-31318.
Published January 20, 2017 - Updated December 2, 2021
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