Support Article
CPM Expert Assist- Lync contacts are not loading post-upgrade
SA-15923
Summary
Customer Process Manager (CPM) Expert Assist contacts do not load in the help window after a system update from Pega 7.1.7 to 7.1.9.
Error Messages
Not applicable.
Steps to Reproduce
- Open a CPM interaction.
- Click on Help to load the CPM Expert Assist contacts.
Root Cause
A defect in Pegasystems’ code or rules.
Resolution
Perform the following local-change:
Update step 3 of the the activity @baseclass FetchContactList PegaFW-Lync:07-13-01 as noted below and save into your custom ruleset.
From:
ClipboardPage ContactList = tools.findPage("pyContentPage");
java.util.ArrayList ResponseProps = new java.util.ArrayList();
ResponseProps.add ("pxResults.LyncContactId");
ResponseProps.add ("pxResults.pyEmailAddress");
Response = pega_rules_page.getPageAsJson(ContactList, ResponseProps);
Response = Response.replace("pxResults", "\"pxResults\"");
To:
ClipboardPage ContactList = tools.findPage("pyContentPage");
java.util.ArrayList ResponseProps = new java.util.ArrayList();
ResponseProps.add ("pxResults.LyncContactId");
ResponseProps.add ("pxResults.pyEmailAddress");
Response = pega_rules_page.getPageAsJson(ContactList, ResponseProps);
// Platform team fixed issue with JSON page (remove workaround)
//Response = Response.replace("pxResults", "\"pxResults\"");
Published January 31, 2016 - Updated December 2, 2021
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