Support Article
CPM Timer does not display properly
SA-10946
Summary
In user's CPM application, they have a custom skin which is copied from out-of-the-box(OOTB) CPM skin in 6.2 version.
After upgrade, user is not able to view the below items in IE 8, IE 11 browser, but, user is able to view the same in Chrome and IE 8 (incompatibility mode).
- 'X' icons on the Intent tabs
- Home icon on right side CPM interaction small tab
- 'X' icons on the Interaction small tab.
Error Messages
No CPM related Icons displayed.
Steps to Reproduce
Run in IE 11, IE8, Chrome and IE 8 in compatibility mode.
Root Cause
The root cause of this problem is a defect in customer application code/rules.
- The custom skin is not compatible with HTML5.
- Inlcude HTML5 document type not checked in application rule form.
- Custom javascript CPMCTICallTimer.
Resolution
This issue is resolved through the following local-change:
1. Refractor the custom skin as per OOTB CPM skin.
2. Checkbox HTML 5 document type in the application rule.
3. OOTB CPMCTICallTimer JS file logic need to be refactored into custom rule.
Published July 2, 2015 - Updated December 2, 2021
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