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Support Article

CRM Interaction tabs do not close when multiple tabs are open

SA-54825

Summary



When multiple tabs are open for some period of time, clicking the 'X' icon (Close) for one of the inactive tabs fails to close the tab.


Error Messages



Not Applicable


Steps to Reproduce

  1. Open multiple tabs.
  2. Leave one of the tabs out of focus, and continue to create and delete other tabs.
  3. When the number of the other tabs created and deleted exceeds 30, click the 'X' icon on the tab which is intentionally left unfocused.


Root Cause



A defect in Pegasystems’ code or rules.

A Requestor level data page called Declare_pzRecentsCache is present which has the pyRecents page list that contains information about the recent work objects and tabs. By default, the list can contain only 30 items. 

If the user opens a work object in a tab and performs other tasks in the other tabs, then the other work objects are also added to the list. If the user does not restore focus to the tab but works on the other tabs (such as creating and deleting other tabs), more than 30 other items will populate the list and the original tab is pushed off the list.

If the user has to restore focus to the tab prior to clicking the 'X' icon, then the work object is restored to the pyRecents list. If the user clicks the 'X' icon directly without restoring focus, then the tab is not re-added to the list. When the work object is not on the list, then the tab is not closed.



Resolution



Perform the following local-change:

Verify if a Dynamic System Setting (DSS) for Pega-UIEngine: pyMaxRecentsCount exists.

If the DSS does not exist, create one and increase its value from the default of 30 to 50.

The goal is to make the setting large enough so the likelihood of the tab being pushed off the list during normal operation is minimal. Although the number can be raised beyond 50 (the values are stored in the database), performance may be impacted.

Published May 11, 2019 - Updated October 8, 2020

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