Skip to main content
This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

'&' in delegated rule displays as '&' in user portal

SA-65531

Summary



In the user portal, '&' in the title and description of a delegated rule displays as '&' on opening it for editing.


Error Messages



Not Applicable.


Steps to Reproduce

  1. Create a data type
  2. Delegate the data type by navigating to Actions > Delegate
  3. In the title and description, provide a text that contains '&'. For example, One & Two 8 Three
  4. From the Case Manager portal, open the list of delegated rules. In the list, the title and description of the delegated rule display correctly
  5. Open the delegated rule by clicking the Edit button. The title displays as 'One & Two 8 Three' and the description displays as 'One &amp&#59; Two 8 Three'


Root Cause



A defect in Pegasystems’ code or rules.
In PZPEGA_UI_DLCELLTEMPLATE!JS, XSS filter is applied in the metadata entry for paramValue.



Resolution

Apply HFix-47209.


 

Suggest Edit

Published October 12, 2018 - Updated December 2, 2021

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us