Support Article
Deleted offer displays on the Marketing portal
SA-85703
Summary
User deletes a class from the Designer Studio using the Delete Class wizard. However, the relevant offer still displays on the Marketing portal.
Error Messages
Status: Failed, please consult your Administrator
Steps to Reproduce
- Delete a class that refers the Marketing Artifacts from Designer Studio
- Go to the Pega Marketing platform
- Search for the deleted offer from Content > Offers
- Click an offer. The offer is not opened. An error message displays
Root Cause
An issue in the custom application code or rules. Deleting the Marketing artifacts from the Designer Studio is not a recommended approach. As the referenced class is deleted from the Designer Studio, the referenced issue is also removed along with the class. Hence, the offer is corrupted.
Resolution
Perform the following local-change:
- Verify the XML content of the offer rule
- Update the valid pyclass(if it is missing as per the XML data) through an activity and delete it from the Marketing Portal
or
- Re-create the same issue
- Group and create an offer with the same name
- Delete the old and newly created Offer
or
- Perform a revalidation of the corresponding class or application
- Verify if the offer rule can be opened
Published September 6, 2019 - Updated December 2, 2021
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