Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Different behaviour in I-Cases and SR Cases

SA-29407

Summary

When opening an Inbound correspodence case from a work basket and close without any modification, the work object will go back to the workbasket.

Error Messages



Not Applicable


Steps to Reproduce

  1. Launch Interaction portal. 
  2. Go to My Workbaskets. 
  3. View the queue for any work basket. Ex: 'Inbound Correspondance' 
  4. Open an I-case and observe that it is moved to work list.


Root Cause



When opening an Service Request case from a work basket and close without any modification, the work object will go back to the workbasket. But for the same scenario in Interaction cases, I- case will be assigned to work list of the user. 

This use case has a problem when coming for Inbound correspondences. I-cases are assigned to a work basket when an Emial/Fax comes in to create an I-cases. For ex- Inbound Correspondence of class PegaCA-Work-Interaction-Incorr. 

OOTB inbound correspondence gets assigned to a work basket. If a user is trying to open the workobject, that is assigned to the worklist of the user.  This happens due to Step 7 in 'CPMPerformDefaults' activity which is an extended version of activity present in class PegaCA-Work-Interaction for I- cases. This was getting called even for Inbound correspondences. 

As part of the hotfix, code is corrected to copy work items to current operator's worklist when opening from workbasket.

Resolution



Apply HFIX-29724.

 

Published October 27, 2016 - Updated December 2, 2021

Was this useful?

100% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us