Support Article
Duplicate error messages on duplicate search
SA-48803
Summary
Validation message displays multiple times when a case is resolved using the ‘Resolve as Duplicate’ option.
Error Messages
Not Applicable
Steps to Reproduce
- Create a simple case type 'Customer'.
- In this class coupled to the 'Customer' case, create a property 'FirstName' of type Text and optimize this property.
- In the case type settings, Track Duplicates, set:
- Weighted conditions: 10 for Primary.pyLabel = .pyLabel (since weighted condition is mandatory)
- Set 'Case is duplicate when sum >= 10'.
- Enable 'Configure must match conditions' and set '.FirstName is same'.
- Open the 'Case Match' pyDefaultCaseMatch decision rule coupled to the class of the case of interest and add an additional must match condition, '.FirstName is not null'.
- Customer case type, refresh settings and confirm the 'Track duplicates'.
Note: .FirstName IS NOT NULL is added to the must match condition. - In the 'Customer' case, add a simple process consisting of an assignment (collect information) and 'search for duplicates' flow utility. The 'collect info' simply accepts FirstName via text input.
- Launch the 'Case Worker" portal and run the 'Customer' case. Enter values to trigger a duplicate match.
- Click to Resolve as Duplicate without selecting an existing case.
Root Cause
A defect in Pegasystems’ code or rules.
Resolution
Perform the following local-change:
- Perform a Save As of the pyDuplicateSearchCasesBtns in the ruleset.
- Change the Resolve As Duplicate button type (from pzActionButton to a normal button).
- Add an action set in the Click event.
a. Run a data transform and mention the name of the newly created data transform (for example, SetDuplicateCaseAction). Add a step in the data transform to set the value of DuplicateCaseAction to a parameter name such as, param.DuplicateActionName. From the action, pass the parameter as Resolved.
b. Add another action, Finish Assignment. - Open the pyDuplicateSearchCases Flow Action Save As and add a post-processing activity (create a new activity),
(for example, PostDuplicateSearchCaseAction). Call the pyPostDuplicateSearchCases existing activity and add a When condition to check DuplicateCaseAction == "Resolved" and an Else Skip step. Open the pyPostDuplicateSearchCases (applied to Work-), Save As and comment Steps 5 and 10. - Save all the changed rules.
Published March 21, 2018 - Updated December 2, 2021
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