Support Article
Email Account SMTP connectivity issue
SA-1795
Summary
When the email account is tested with the Test Connectivity button, the result displays the Connect to email sever: Fail step.
Status is a secure connection that cannot be established with the outgoing (SMTP) email server. However, the email server accepts the non-secure connection which is verified by Telnet to the email server port 25. When the Simple Mail Transfer Protocol (SMTP) command is manually provided, the email is sent successfully.
Error Messages
Connect to email server: Fail
Steps to Reproduce
Unknown
Root Cause
A defect in Pegasystems’ code or rules. The issue is due to the email server enabled STARTTLS and PRPC automatically switching to STARTTLS support.
Resolution
Perform the following local-change:
- Create a Dynamic System Setting (DSS) with name, Email/DisableSecuritySTARTTLS, in the Pega-IntSvcs ruleset whose value can be either True or False
- Set the value of the DSS to True
- Restart the server
Published October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.