Skip to main content

Support Article

Email Attachment Taking unusually long time and failing sometime

SA-29263

Summary



Email attachment triggered by the email Listener is either taking unusually long time or failing to attach at all to the work object.

Error Messages



Not Applicable

Steps to Reproduce

  1. Send an email with an large attachment (e.g.: 13 MB) to email account
  2. Listener picks the email to process
  3. Enable DEBUG on EmailListener and you will see processing will take long time.

Root Cause



Default JavaMail used an IMAP feature called "partial fetch" which will allow you to download a small portion of the mail attachment at a time.  This feature will avoid retrieving big attachment and store them entirely in the heap but will lengthen the time to download the attachment.  Default fetch size is 16kb.

Resolution



Apply DSS Pega-IntSvcs email/fetchsize with value 1024000.
Suggest Edit

Published October 27, 2016 - Updated October 8, 2020

Did you find this content helpful?

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Ready to crush complexity?

Experience the benefits of Pega Community when you log in.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us