Support Article
Email listener not starting but test connections work fine
SA-16045
Summary
Email Listener is not starting in PRPC 6.1 SP2. Test connections from the Listener and Email Server rules work fine, but when trying to start the listener via SMA an error is thrown. The error references port 465, but this is not specified on our rule forms.
Error Messages
2015-10-16 06:44:05,465 [your_host.com] [ STANDARD] [ ] (tener.ListenerStateManagerImpl) ERROR - Unexpected exception.
com.pega.pegarules.pub.PRException: Failed to connect to your_email_server
Caused by:
javax.mail.MessagingException: Could not connect to SMTP host: mail.host.com, port: 465;
nested exception is:
java.net.ConnectException: Connection refused
Steps to Reproduce
Not applicable.
Root Cause
An issue in the custom application code or rules caused the issue. The email listener rule form has a "Send Reply Via Email Server" property that one can specify. The email listener will use the hostname specified on that email server rule along with port 465 to attempt to send an email.
Resolution
Perform the following local-change:
The email server rule specified for "Send Reply Via Email Server" must have the correct SMTP host value that is required. Alternatively, the following Dynamic System Setting can be created and set to true, which stops the email listener from trying to connect using SMTP and prevent it from sending replies:
Owning Ruleset: Pega-IntSvcs
email/blockResponse
Published January 31, 2016 - Updated October 8, 2020
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