Support Article
Email Listener processes single emails for a long time
SA-67913
Summary
An email listener processes single emails for long periods of time and multiple errors are generated in the log. Processing continues, but is slow.
Error Messages
[EMAIL-Thread-2223] [STANDARD] [ ] [app:01.03.01] (services.email.EmailListener) ERROR EMAIL.CreateEmailResponseProcessor.Listener|from([email protected])|sub(your_email_subject) your_pega_user - Caught unexpected FolderClosedIOException. Will attempt to mark mail as 'seen'.
com.sun.mail.util.FolderClosedIOException
[EMAIL-Thread-2223] [STANDARD] [ ] [NBIUWWB:01.03.01] (services.email.EmailListener) ERROR EMAIL.CreateEmailResponseProcessor.Listener|from([email protected])|sub(your_email_subject) your_pega_user - Caught unexpected MessageRemovedIOException. Will attempt to mark mail as 'seen'.
com.sun.mail.util.MessageRemovedIOException
Steps to Reproduce
Not Applicable
Root Cause
According to the 'com.pega.pegarules.integration.engine.internal.services.email.EmailListener' debug, attachment processing was slow when attachments were larger than 10 MB.
Resolution
As a local-change, create the following Dynamic System Setting (DSS):
Owning RuleSet: Pega-IntSvcs
Purpose: email/fetchsize
Value: 1024000
Published December 27, 2018 - Updated October 8, 2020
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