Support Article
Email listener sporadically fails with connection reset error
SA-56375
Summary
Email listener sporadically fails with connection reset error.
Error Messages
[.PegaWorkManager : 4] [ STANDARD] [ ] [ PegaRULES:07.10] ( services.email.EmailListener) ERROR EMAIL.your_EmailListener.Listener - Caught exception while connecting to email server(s)
javax.mail.MessagingException: Connect failed;
nested exception is:
java.net.SocketException: Connection reset
at com.sun.mail.pop3.POP3Store.protocolConnect(POP3Store.java:161)
at javax.mail.Service.connect(Service.java:288)
...
Caused by:
java.net.SocketException: Connection reset
at java.net.SocketInputStream.read(SocketInputStream.java:208)
at java.net.SocketInputStream.read(SocketInputStream.java:134)
Steps to Reproduce
Unknown.
Root Cause
A defect or configuration issue in the operating environment. Enabling debug on 'com.pega.pegarules.integration.engine.internal.services.email.EmailListener' and capturing network data, displayed that the Pega application received a response from the email server after 60 seconds from the initial connection attempt. Hence, the process had timed out.
Resolution
Perform the following local-change:Create a Dynamic System Setting to increase the timeout:
Owning Ruleset: Pega-IntSvcs
Purpose: email/timeout
Value: <timeout in milliseconds>
Published April 26, 2018 - Updated October 8, 2020
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