Support Article
Email Listeners will not start, unable to connect
SA-41814
Summary
Servers hosting Pega were moved from an old network domain to a newly created domain. Since the domain change, email listeners will not connect. Error indicates that it cannot connect to the email server.
Error Messages
Listener 'Data-Admin-Connect-EmailListener:Listener.your_email_listener(com.pega.pegarules.integration.engine.internal.services.email.EmailListener)/0' failed to start because of the following error:
Failed to launch listener, com.pega.pegarules.pub.PRException: Email listener 'Listener.your_email_listener' failed to connect to Email Server - From: (BA4D7B309502353F57A1B818DD13A282D:(MBean Access))
Steps to Reproduce
Not applicable
Root Cause
A defect or configuration issue in the operating environment. An internal DNS (Domain Name Service) issue was preventing the Pega application from reaching the email server using its hostname.
Resolution
Perform the following local-change: Specify the IP address of the email server instead of the hostname.
Published August 24, 2017 - Updated October 8, 2020
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