Support Article
Error on calling Pega Survey post upgrade to OAM 11g
SA-56855
Summary
Error occurs when calling Pega Survey after upgrading to Oracle Access Manager (OAM) 11g.
Error Messages
BAD Oracle Access Manager Request.
Steps to Reproduce
- Launch the application
- Change the URLs from OAM10g to OAM11g
- Log in to the Internet Application Composer (IAC) and call Pega Survey
Root Cause
When using IAC, a cookie is created. With OAM10g, the traffic could flow from IAC to the Pega application just using the IAC cookie. With OAM11g, a second cookie is required for the same process.
Resolution
Perform the following local-change:
Generate an application cookie and pass it along with the IAC cookie.
Published July 23, 2018 - Updated December 2, 2021
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