Support Article
Error with delete: This Operator has rules checked out
Summary
User is trying to delete an operator but is not able to delete. The system says that there are checked out rules for the user but when user views the rules there are no checked out rules.
Error Messages
Error with delete: This Operator has rules checked out . They must be checked in before the operator can be deleted.
Steps to Reproduce
Login to the system Go to organization Operator ID and select the Operator and click delete
Root Cause
This Operator has rules checked out.
Resolution
PRPC does not prohibit deletion of an Operator ID instance when there are open assignments on that operator's worklist, or when that Operator ID is referenced in another data instance (such as an organization unit or workbasket).
If a user is no longer active, rather than deleting the Operator ID instance, follow these steps:
- Ensure that this user is not currently logged in.
- Transfer or complete all assignments on the worklist.
- Update the password to a value that is not disclosed to the user, so that person can no longer log in.
- Ensure that this user has no rules checked out. If not, sign on and delete or check in the checked-out rules.
- Clear the Operator is available to receive work? check box.
- Enter a departure date in the Unavailable from array.
- Enter a substitute operator for assignments routed to this operator.
- Save the updated Operator ID instance.
Operator ID cant be deleted if operator has rules checked out. Have the operator sign in, and delete or check in all rules in the operator's personal RuleSet.
Published April 10, 2016 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.