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Support Article

Exception on configuring SMA for Tomcat

SA-76046

Summary

Exception generates while configuring System Management Application (SMA) for the Tomcat.


Error Messages

pega.jmx.ui.util.JMXClientException: Cannot connect to the server with specified settings 
Failed to retrieve RMIServer stub: javax.naming.ServiceUnavailableException [Root exception is java.rmi.ConnectException: Connection refused to host: localhost; nested exception is: java.net.ConnectException: Connection refused: connect] at pega.jmx.ui.util.JMXClientException.wrap(JMXClientException.java:49)

 

Steps to Reproduce

Open the System Management Application. 


Root Cause



Java Management Extensions (JMX) was disabled.

Resolution

Perform the following local-change:

  1. Enable the JMX port on the server
  2. Execute the Tomcat's JVM with the below parameters:
    -Dcom.sun.management.jmxremote=true
    -Dcom.sun.management.jmxremote.port=8686
    -Dcom.sun.management.jmxremote.ssl=false
    -Dcom.sun.management.jmxremote.authenticate=false 
 

 

Published August 19, 2019 - Updated October 8, 2020

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