Support Article
Export to Excel issue in Report Definition
Summary
When performing Export to Excel from a report definition, error occurs intermittently. Additionally, all the rows are not exported.
Error Messages
There has been an issue. Please consult your system administrator.
Steps to Reproduce
Export to Excel in the report definition.
Root Cause
A defect in Pegasystems’ code or rules.
The issue occurred due to the following:
- HTTP interaction exceeded the elapsed time alert threshold of 1000 ms: 5262 ms.
- Out of heap space.
- Caused by: java.lang.IllegalArgumentException: The maximum length of cell contents (text) is 32,767 characters
Resolution
Perform the following local-change:
1. HTTP interaction exceeded the elapsed time alert threshold of 1000 ms: 5262 ms. This indicates that the query took long to run. Perform the below steps for this issue,
(i). Open the report definition > Data Access Tab.
(ii). Increase the values for the following parameters:
- Maximum elapsed time in seconds
- Maximum elapsed time in seconds for export
- Maximum number of rows.
2. According to the length exception, there is a limit in Excel itself (apparently as enforced by the Apache utility).
(i). Ensure that cells do not exceed that limit.
(ii). Run the report manually (examine the data if needed).
(iii). Truncate the data if required, or export to CSV if data is essential.
Published February 24, 2019 - Updated December 2, 2021
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