Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Failed to find current installed version of Pega upgrading data

SA-71505

Summary



The Upgrade script fails when upgrading the Data Schema. Hence, unable to upgrade the UAT system.


Error Messages



Failed to find current installed version of PRPC (UpgradeDataModelImpl) INFO - Installed Product Versions: 
(UpgradeDataModelImpl) INFO - {Instance: PEGARULES PROCESS COMMANDER!7.3.0, version: null, build name: PRPC-7.3.0-126} (current version)



Steps to Reproduce



Run the update.sh --dataOnly=true


Root Cause



The Rules schema was created from an installation of Pega 7.3 and moved to the UAT system. The installation did not populate the pySetting column which determines the version running for the Data Schema upgrade.


Resolution



Perform the following local-change: 
  1. Update the pySetting column in the pr_data_admin_product table to reflect the correct version.

    UPDATE rules.PR_DATA_ADMIN_PRODUCT SET pysetting='07-10-31' WHERE PXOBJCLASS = 'Data-Admin-Product' AND PXPRODUCTNAME='PegaRULES Process Commander' AND PXINSNAME NOT LIKE '%CUSTOMER%'; 
    commit;

     
  2. Restart the Upgrade script.

Published February 8, 2019 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us