Support Article
Few fields not populated in Clinical Interaction Manager
SA-32012
Summary
User request to provide hotfix for addressing post release issues found in Clinical Interaction Manager (CIM) 7.21 which comes under CSHC license.
Issue 1: Primary care provider details are blank in Patient tab.
Issue 2: Specialty column dropdown is not having any values while creation of authorization request.
Issue 3: When the created authorization request is opened in Pega Care Management Application for HealthCare (CMA), the servicing provider details are coming as blank when any other provider is selected in interaction portal.
Issue 4: CMA defaults ICD10 for Diagnosis code set type but CSHC defaults ICD9.
Isssue5: Description is missing for some of the codes in CSHC - The property ‘DiagnosisDescription’ for some of the diagnostic codes is empty in the sample data. CIM is using a data page D_DiagnosisCodeSearchResults (which is the same in CMA 7.1.4) whereas CMA moved to a different data page D_GetDiagnosisCodes which is mapping ‘ShortDescription’ to ‘Description’ as in screenshots below.
Issue6: For an authorization created in CIM, Policy role is coming as blank in ‘Patient’ composite on CMA layer.
Error Messages
Not applicable
Steps to Reproduce
Not applicable
Root Cause
A defect in Pegasystems’ code or rules.
Issues reported are found during testing of CIM 7.21 on CMA 7.21 application.
Initially CIM 7.21 was released on CMA 7.14 and after the GA of CMA 7.21 the compatibility testing was performed on CIM 7.21 on CMA 7.21 and above listed issues (Summary) are found.
Resolution
Apply HFix-31208.
Published January 12, 2017 - Updated December 2, 2021
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