Support Article
Grid filtering functionality for Bulk Actions does not work
SA-68254
Summary
Case filtering functionality for Bulk Actions does not work when using the Filter property.
Error Messages
Not Applicable
Steps to Reproduce
- Navigate to the Bulk Actions page.
- Select a process.
- In the Process cases section, add an extra filter with a new property such as Case ID.
- Click Filter Cases.
Root Cause
pyFilterValue was not set for the newly added condition in the pyConditionList. This occurs for those properties which have controls other than autocomplete in the filter value column.
Resolution
Perform the following local-change:
Add a Post Value action in the pyDisplayPropertyTypeInBulkProcessNonSpl section for the corresponding control.
Published November 29, 2018 - Updated December 2, 2021
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