Support Article
Impression not captured for campaign mails sent to Gmail
SA-41166
Summary
Unable to capture impressions for campaign mails sent to Gmail.
Error Messages
Not Applicable
Steps to Reproduce
- Create a campaign and select the target audience
- Set the goals: Total sent, Impressions rate, Total impressions, Outbound conversion rate, Click-through rate any value
- Configure the proposition data to send the email
- Set the sample treatment in the offer
- Load the prospect list (which are Gmail IDs). If the list does not exist, create it from Segmentation
- Allow the engagement to run the campaign once
Root Cause
An issue in the custom application code or rules.
During debugging, the impressions were captured only for emails that were sent internally within the user network. When the offer emails were sent to other mail IDs (for example, Gmail), the responses were not captured.
The IP address, in the URL, that was sent out as part of the offer mail to capture the impressions was not available publicly.
Resolution
Here’s the explanation for the reported behavior:
The IP address must be visible to external user networks to capture the responses.
Published September 29, 2017 - Updated December 2, 2021
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.