Support Article
Interaction History does not display in the Marketing portal
SA-83349
Summary
Interaction History in the database does not display in the Pega Marketing portal.
Error Messages
Not Applicable
Steps to Reproduce
- Run the following REST Request for the URL: https://myurlx.org/prweb/PRRestService/PegaMKTContainer/V2/Container
{
"CustomerID": "Linda",
"ContainerName": "NextBestAction",
"Channel": "Web",
"Direction": "Inbound",
"InputSegment": "Segment1"
}
Observe the Interaction History records in the database table.
SELECT COUNT(*) FROM pegadata.PR_DATA_IH_FACT
ORDER BY PXOUTCOMETIME DESC
Fetch only the first 10 rows;
- Check the Pega Marketing portal Interaction History feature.
Root Cause
An issue in the custom application code or rules.
The values in pyapplication and pystrategy in the pr_data_ih_dim_application table were null. Therefore, the values did not display for the Interaction History in the Pega Marketing portal.
Resolution
Perform the following local-change:
Insert or update the correct values instead of null for pyapplication and pystrategy in the pr_data_ih_dim_application table.
Published December 2, 2021
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