Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Issue with timeout not able to reconnect

SA-27952

Summary



Developer set a timeout of one hour on users and admin access groups.

If user leaves the screen open, they will get a popup window asking for credentials.

But whatever values that are entered, then it is not accepted. User tried several PRPC operators, WebLogic accounts, even Windows account data.

User is on authentication with WebLogic or PRPC.

The issue happened first right after they configured the timeouts and user has not witnessed any timeouts before.


 

Error Messages



None, but the affected users are not able to continue working.


Steps to Reproduce

  1. Configure access group timeout.
  2. Wait for timeout and popup window to provide username and password.


Root Cause



A defect or configuration issue in the operating environment.

Resolution



User faced two issues. following are the resolution:

First, a WebLogic issue with HTTP authentication that is described there, together with a solution:

https://pdn.pega.com/troubleshooting-weblogic-error-when-http-basic-authentication-enabled-soap-service

Second, their authentication is using a type of PRExternal instead of a type of PRCustom. User must switch to PRCustom.

Published September 21, 2016 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us