Support Article
Mails are not triggered to Participants
SA-82225
Summary
When creating cases, mails are not triggered to the Participants in all environments post migration to Pega Platform 8.1.4 from Pega Platform 7.4.
Error Messages
Error sending email: PRRuntimeException
Steps to Reproduce
- Create an activity.
- Call the SendEmailNotification out-of-the-box activity by passing the required parameters. In the 'To' parameter, pass emailID with a comma (for example, '[email protected],').
Root Cause
When the SendEmailNotification out-of-the-box activity was called, the parameter value was appended with a comma. Before the SendEmailNotification activity was invoked, the Property-Set method was called, where the 'To' parameter value was assigned. The 'To' parameter value was configured such that two email's are added with a comma as the delimiter (FirstEmailID,SecondEmailID). However, when the second email ID is populated as null, the 'To' parameter had the FirstEmailID, which caused the error.
Resolution
Perform the following local-change:
- Add a condition to check if the SecondEmailID is null.
- If the SecondEmailId is null, then the 'To' parameter must contain only the FirstEmailID, else append the comma and the SecondEmailId with the FirstEmailID.
Published August 19, 2019 - Updated December 2, 2021
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