Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Missing RequestType Field Values

SA-11047

Summary



User upgrades their CPM based application built on  PRPC 6.2 to Pega 7.1. They are setting "RequestType" property in each interaction and intent class default data transform.
It works fine in PRPC 6.2, after upgrading when creating any interaction or intent, its throws error on the screen.


Error Messages



Request Type: Class key validation failed for class: Rule-Obj-FieldVaue, class key value PegaCA-Work/RequestType/Change Plan, Reason:Instance not found.

Steps to Reproduce



1.Set RequestType to some text in Data transform of the Interaction and Intent class.
2.Create any interaction/intent from CPM user portal.


Root Cause



The root cause of this problem is a backwards compatibility defect in Pegasystems’ code/rules. A  new classkey property level validation is introduced which causes the error.

Resolution



This issue is resolved through the following local-change:

In Pega 7.x, user can either over-ride this property or they must add the field value. Although this does not fully sync with the earlier version of CPM, this is in fact an additional constraint being introduced by the product management after due consideration. 

Published July 3, 2015 - Updated December 2, 2021

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us