Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

MTOM MIME Encoding does not remove xsd:base64Binary type



When generating a Message Transmission Optimization Mechanism (MTOM) Attachment request from Pega, the xsi:type="xsd:base64Binary" tag is not removed from the Request XML after encoding. This results in XML Schema Validation errors.

Error Messages

Base 64 not encoded as MTOM MIME

Steps to Reproduce

  1. Configure a SOAP Connector with SOAP 1.1, HTTP 1.1, and MTOM Enabled 
  2. Utilize the XML Stream rule for the message body with a non-auto Generated XML and SOAP 1.1 Encoding.
  3. Include the type="xsd:base64Binary" tag for the MTOM file content. File content is sent as MTOM Encoded. However, the xsd:base64Binary tag is retained.

Root Cause

A defect in Pegasystems’ code or rules.


This feature is implemented in Pega Platform 8.1.8.  

Published April 9, 2020 - Updated December 2, 2021

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us